---
title: "Cannot Edit Instance or Troubleshoot Enterprise Nodes in a Proxy Environment"
slug: "cannot-edit-instance-or-troubleshoot-enterprise-nodes-in-a-proxy-environment"
updated: 2023-09-25T22:06:51Z
published: 2023-09-25T22:06:51Z
---

> ## Documentation Index
> Fetch the complete documentation index at: https://docs.catchpoint.com/llms.txt
> Use this file to discover all available pages before exploring further.

# Cannot Edit Instance or Troubleshoot Enterprise Nodes in a Proxy Environment

### Symptoms

User is unable to use the **Edit Instance** or run the **Troubleshoot** feature when the node instance is deployed in a proxy environment, however the machine where the node is installed is in the local network and it can be pinged successfully from the user's machine.

When clicking **Edit Instance** the following error is displayed: "The portal could not connect to the Instance. Some data could not be retrieved."

When running the **Troubleshoot** feature on an instance it fails with the following error:

```
The portal could not connect to the Instance due to the following reasons:

1. The IP Address/Hostname is incorrect or unavailable.
2. The Instance Software is not updated.
3. The Instance is not connected to the Network.
4. An instance may not be on the same network as the portal.
```

### Cause

The troubleshooting tool relies on API calls over HTTPS to the node instance to perform any editing or troubleshooting functions. The node is in the local network of the user; however, because the user's browser is making a request to the API via a domain, the browser is sending the requests through the proxy, which fails to route the request.

### Solution

To resolve the problem you must modify the OS proxy settings on the machine you are using to access the Catchpoint Portal, and specify that browsers should not use the proxy for the domain of the API: ***.cpnode.net**

#### In Windows 10:

1. Click **Start** Button  ![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005306111-mceclip0.png)
2. Click **Settings** Icon  ![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005306131-mceclip1.png)
3. Search for **Internet Options**
4. Click **Internet Options**

**In older Windows versions:**

1. Click **Start** Button
2. Click **Control Panel**
3. Search for **Internet Options**
4. Click **Internet Options**

After launching **Internet Options**, follow these steps:

1. Click on the **Connections** tab
2. Click **LAN Settings** button.
3. Click **Advanced** and type ***.cpnode.net** in the **Exceptions** area, then click **OK**.

![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005286992-mceclip2.png)

If the troubleshooting tool still does not work, follow the same steps as above and add to the exceptions the internal IP address of the node machine.

**In macOS X:**

1. Click **Launchpad**  

![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005287012-mceclip3.png)
2. Click **System Preferences**  

![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005306151-mceclip4.png)
3. Click **Network**  

![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005287032-mceclip5.png)
4. Select the **Interface** the machine is using
5. Click **Advanced**  

 ![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005287172-mceclip10.png)
6. Click **Proxies**, and type ***.cpnode.net** in the **Bypass proxy settings for these Hosts & Domains** area, then click **OK**.   

 ![](https://cdn.document360.io/cb4af8f9-6751-4fd2-b39c-07aae832badb/Images/Documentation/360005306231-mceclip9.png)
